Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 24, 2026 - 10:00 UTC
Scheduled
On 2026-06-24, we're introducing cryptographic signatures on outgoing webhooks, following the open Standard Webhooks specification. This lets you verify that a webhook genuinely came from FarPay and was not altered in transit.
This is a purely additive change:
- The payload is unchanged. - Existing headers are unchanged.
These are new headers only, so integrations that ignore unrecognized headers continue to work exactly as before.
Verifying the signature is optional but recommended for added security. If you'd like to validate incoming webhooks, see our verification guide: https://farpay.github.io/Webhook/WebhookSignatureVerification.html. Signatures are only included for endpoints that have a signing secret configured.
We don't anticipate any disruption. If you have questions, please contact support.
Posted Jun 18, 2026 - 13:09 UTC
This scheduled maintenance affected: Integrations (Webhooks).